Texas results in!!!! - Page 3 - APR 2017 - Engineer Boards
Jump to content
Engineer Boards
 photo CHPE_AnimatedWebBanner_650x1202_zps5704d467.gif
Sign in to follow this  
4everalone

Texas results in!!!!

Recommended Posts

1 hour ago, mike312c said:

TBPE hasn't updated/released grades on their portal yet so I don't know. Will post here once I find out. 

Are they released the same day normally?

Share this post


Link to post
Share on other sites
2 minutes ago, Aubs said:

I WAS TOLD THE GRADES SHOULD BE UP TOMMORROW.  HOW DO I ADD PE TO MY NAME HERE?

Can't change your screen name unless you're a supporting member.

  • Like 1

Share this post


Link to post
Share on other sites
Just now, RockyTop said:

Can't change your screen name unless you're a supporting member.

DAMN. I'LL LOOK INTO THAT NOW.

Share this post


Link to post
Share on other sites

PASSED!!!!

Thank you board for helping me go through this tough waiting for the results time!

IMG_1495738814199.jpg

Share this post


Link to post
Share on other sites
54 minutes ago, EhmayWuntee said:

To verify, you guys only see NCEES results and nothing on TBPE for your score, correct?

 

42 minutes ago, aggieliz said:

For the record, I logged into TBPE (The link they emailed when they told me they'd received all my application documents) and got this:

"Our system indicates that your PE license was successfully issued 5/25/2017 and that your PE number is XXXXX. Please log in to ECHO to manage your license."

And I've already set up an account on ECHO.  Of course the scores aren't posted yet, though.

I can confirm both of these.

http://engineers.texas.gov/status

Share this post


Link to post
Share on other sites
54 minutes ago, EhmayWuntee said:

To verify, you guys only see NCEES results and nothing on TBPE for your score, correct?

 

42 minutes ago, aggieliz said:

For the record, I logged into TBPE (The link they emailed when they told me they'd received all my application documents) and got this:

"Our system indicates that your PE license was successfully issued 5/25/2017 and that your PE number is XXXXX. Please log in to ECHO to manage your license."

And I've already set up an account on ECHO.  Of course the scores aren't posted yet, though.

I can confirm both of these.

http://engineers.texas.gov/status

Share this post


Link to post
Share on other sites
2 hours ago, Civil By Day said:

I definitely failed. Searching through my diagnostics now. At least the painful wait is over!

I experienced this feeling last October do not give up keep head up you will get it next time, No I am glad I passed.

 

Share this post


Link to post
Share on other sites
8 minutes ago, jdayrail said:

Congratulations to all who passed.  Unfortunately, I did not pass the Construction PE. 

Not to be invasive, but how did you do compared to your level of study? I don't want exact numbers, just how you personally felt about it. I took Construction and I'm trying to hone my studying this next time around, but I was doing well on the practice exams and the problems I was working and then got completely bamboozled by the types of questions on the actual exam. And I did testmasters, so I don't know what additional study courses would do for me. I want to see if others worked a ton of practice exams and still failed or if I have some hope in using the next five months to see as many problems as I possibly can for when I go in next time.

Share this post


Link to post
Share on other sites

Congratulation to everyone who passed. Hard luck and to those who failed, enjoy the memorial holiday and keep working hard you can get it next time.

Share this post


Link to post
Share on other sites

NOT TODAY SATAN!

Grade.PNG

Share this post


Link to post
Share on other sites
9 minutes ago, spacebanjo said:

Passed. 98! Woot! May have overstudied... Thank yall for the help. 

Screenshot_20170525-164649.png

Wow, that is REALLY good work there, which depth and did you feel like it went that well upon leaving the exam?
I ended up with an 80% which is near the upper end of my range of assumed score.

 

Share this post


Link to post
Share on other sites

I took mechanical Thermal Fluid Systems and felt very good about it after leaving -- although I had paranoid thoughts after that I had misbubbled or something. 

Currently vacationing in Mexico so 98 tequilas para mi! 

Share this post


Link to post
Share on other sites

Just saw my score on Chemical - 97%. Apologies - I'm not posting to boast, but I told a few other folks on this thread who asked that I would post when I saw it. 

For anyone curious about Chemical - I self-studied with Lindeburg ChERM, Six Minute Solutions, Practice Problems, the Lindeburg practice exam, the official NCEES practice exam, and also had the Lindeburg Quick Reference guide handy. Used Perry's as well. 

Congrats to all who passed, and if you are planning to take it again, all the best in October. 

Share this post


Link to post
Share on other sites

Just started first beer.  Maybe next a glass of wine and i can conjure the courage to open the result page.  Ive held out 4 hrs already.

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...