South Carolina results? - OCT 2016 - Engineer Boards
Jump to content
Engineer Boards
Sign in to follow this  
ScurvyBones

South Carolina results?

Recommended Posts

I wonder what the hold up is.  Usually SC is one of the first ones to release.  

Share this post


Link to post
Share on other sites
Just now, SK82 said:

I wonder what the hold up is.  Usually SC is one of the first ones to release.  

NCEES is trolling its home state for funzies

Share this post


Link to post
Share on other sites
29 minutes ago, ScurvyBones said:

IMG_7470.PNG

 

 

The results are in, they just have to give permission to release, right?

 

 

 

Share this post


Link to post
Share on other sites

If I recall correctly, South Carolina was released later afternoon the 2nd day after the initial mass release of scores so I predict you'll be getting the email from NCEES around 3 PM this afternoon.

Share this post


Link to post
Share on other sites

It sucks having to wait longer, especially if I failed.  

I would love to know what goes on behind the scenes for a board to not just release the results.  Are there some test scores that are borderline that they would deem pass or fail based off their own criteria?  What would be different from the April test for them to not release score quickly like last time?  

This test has really been a burden, I can't break out the Christmas music and Home Alone like I want to.  My Christmas tree is still in the attic so now I'll be mopping around this weekend getting it ready but thinking about my results.  

I guess the bright side is, we have a few more days to be hopeful that we passed.  

 

 

 

 

Share this post


Link to post
Share on other sites

I checked my llr account around 1:00 and it said that i had no pending applications. When i checked my internet history to go to my application status (where it said PE result pending) it says i passed, but i can no longer access that page. Has anybody experienced this?

 

Share this post


Link to post
Share on other sites
8 minutes ago, ClemsonEngineer said:

I passed!  I checked my llr account and clicked on view my pocket card.  It showed up my EIT and my PE with today's issue date.  Ncees still shows nothing.

Ah man I wish I could check that, I opted to take it early so I wouldn't be issued a license yet.  It did change my pending applications from showing my PE application checklist and results pending to just saying that there are no pending applications.  Just want to know the results!

 

And congrats to you!

Share this post


Link to post
Share on other sites
8 minutes ago, ClemsonEngineer said:

I passed!  I checked my llr account and clicked on view my pocket card.  It showed up my EIT and my PE with today's issue date.  Ncees still shows nothing.

Can you do that only if you've applied for licensure in SC? I only applied to take the exam so I don't have an account with LLR.

Share this post


Link to post
Share on other sites
8 minutes ago, ClemsonEngineer said: I passed!  I checked my llr account and clicked on view my pocket card.  It showed up my EIT and my PE with today's issue date.  Ncees still shows nothing.

Can you do that only if you've applied for licensure in SC? I only applied to take the exam so I don't have an account with LLR.

I would also like to know the answer to this question. I don't believe I have an account through South Carolina as I am from Florida and just registered to take exam early through South Carolina.

Sent from my SM-G930V using Tapatalk

Share this post


Link to post
Share on other sites

What does your application status show on your like account?

Edited by SK82

Share this post


Link to post
Share on other sites

I tried this and did not see any update. However when i try to update my home address there is a license number associated with my account. Not sure if this means anything or not. 

Share this post


Link to post
Share on other sites
1 hour ago, JeeperCreeper said:

I would also like to know the answer to this question. I don't believe I have an account through South Carolina as I am from Florida and just registered to take exam early through South Carolina.

Sent from my SM-G930V using Tapatalk

I also registered for early exam. Looks like I still have an account on their system. Just do forgot user id and then forgot password to reset the password.

https://eservice.llr.sc.gov/SSO/Login/LoginPage?ReturnUrl=%2fSSO

I also got " You currently have no pending applications on file."

 

Share this post


Link to post
Share on other sites
1 minute ago, staringatmonitor said:

I also registered for early exam. Looks like I still have an account on their system. Just do forgot user id and then forgot password to reset the password.

https://eservice.llr.sc.gov/SSO/Login/LoginPage?ReturnUrl=%2fSSO

I also got " You currently have no pending applications on file."

 

Ok, same here

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...